Install GNS3 1.0 on Fedora

Recently started to play around with the new GN3 1.0 release on my Fedora 20 laptop. Just a quick guide to installing since the official notes only seem to mention apt/debian. On a side note the new 1.0 releases are starting to look awesome already πŸ™‚

Install dependencies (updated for Beta 1)

sudo yum install git python3-devel python-pip python3-setuptool python3-PyQt4 python3-zmq python3-tornado python-netifaces

Grab iouyap and move to bin

tar xzf iouyap.tar.gz
sudo mv iouyap /usr/local/bin/

No we have all the dependencies sorted we can grab the gui, server software and dynamips to get installed.

git clone
git clone
git clone

Now lets install

cd gns3-gui
sudo python3 install
cd ../gns3-server
sudo python3 install
cd ../dynamips
sudo make install

Start gns3 with gns3 job done πŸ™‚
Then for all future updates to the alpha etc just rerun the git clone and install the new updates



  • BTW,if you decide to go the “source code” way, you’ll need more work to do.

    Sine alpha 2 python3-tornado 3.1.2 is minimum requirement. in the official repositories you have an older version. You need to compile that.

    Also you need to compile python3-ws4py and python3-apache-libcloud

  • Hi again Andrea

    I wrote this guide installing alpha 2 and didn’t need to compile anything above whats in the post. I dont have much experience with opensuse and mixing packages with Fedora etc so I’d prefer to stick with what I know in that respect. Both options are available on this page now though so people can pick the best option for themselves? πŸ™‚
    Cheers again


  • I get the following error…

    [root@localhost gns3-gui]# python3 install
    Traceback (most recent call last):
    File “”, line 19, in
    from setuptools import setup, find_packages
    ImportError: No module named ‘setuptools’

    I get this in both gns3-server and gns3-gui folders even if I follow the instructions…I have been looking around or should I say “Googling” it…but no luck…I am able to run this Alpha 3 version in Windows 7 Home Premium in my Dual-boot Dell Studio 15 Laptop…

    Any help would be greatly appreciated…Thanks.

  • Thanks m00nie…ithought I installed python3-setuptools in my Fedora20…hence I was surprised to see the error message I posted earlier..

    however I did install the via wget -O – | python

    after this i ran the “python3 install” in both my gns3-server-alpha1 & gns3-gui-alpha1 Folders…Bingo…I got my GNS3-Alpha1 up & running in my Fedora 20…

    Thankyou very much for the help…much appreciated !!!

  • Andrea,

    I want an easier life but that yum-config command doesn’t work for me. Any thoughts? (yep, Linux Newbie)

  • In Fedora 20 to solve the error, just install

    Warning: Failed to build or run libzmq detection test.