EIGRP (Named vs Legacy)

Just a quick look over the basic differences with the newer style of EIGRP config. It really is quite a bit nicer (more logcal?) layout in the config with things like authentication moving under the eigrp config so its easy to see related config under one section of show run etc 🙂

I’ve used this topology in GNS3 to compare the config and try to show old vs new styles. screen

Assuming everything has basic connectivity to directly connected neighbours  we’ll start by bringing up a simple relationship between Old and New routers with Old using the old legacy syntax and New the ‘named’ config style.

Old:

router eigrp 1
network 1.1.1.1 0.0.0.0
network 192.168.12.0
no auto-summary
eigrp router-id 1.1.1.1

New:

router eigrp weee
!
address-family ipv4 unicast autonomous-system 1
!
topology base
exit-af-topology
network 2.2.2.2 0.0.0.0
network 192.168.12.0
no auto-summary
eigrp router-id 2.2.2.2
exit-address-family

So not a huge difference between the two? In this very basic setup the named option does look more unnecessarily complicated for no benefit but lets stick with it and see if adding some authentication will make any difference. Assuming both routers have a key chain called myKey with matching keys.

Old:

interface Ethernet0/0
ip authentication mode eigrp 1 md5
ip authentication key-chain eigrp 1 myKey

New:

router eigrp weee
!
address-family ipv4 unicast autonomous-system 1
!
af-interface Ethernet0/0
authentication mode md5
authentication key-chain myKey
exit-af-interface

Now we start to see the benefits! Logical layout in the config where we configure eigrp authentication under eigrp!! A side note that sha256 should also be available if you are running the newer code and md5 isnt considered the most secure anymore.
Now lets configure a legacy style stub on Old_Stub but inject a default from New into this stub area

Old_Stub:

router eigrp 100
network 192.168.23.0
no auto-summary
eigrp stub connected

New:

router eigrp weee
!
address-family ipv4 unicast autonomous-system 1
!
af-interface Ethernet0/1
summary-address 0.0.0.0 0.0.0.0
exit-af-interface
!
network 192.168.23.0

Again not a huge difference but nice logical (and obvious??) config for the summary default.
As a finial comparison lets configure New_Stub as a stub router using authentication

New_Stub:

router eigrp somethingelse
!
address-family ipv4 unicast autonomous-system 1
!
af-interface Ethernet0/2
authentication mode md5
authentication key-chain myKey
exit-af-interface
!
topology base
exit-af-topology
network 4.4.4.4 0.0.0.0
network 192.168.24.0
eigrp stub connected
exit-address-family

New:

router eigrp weee
!
address-family ipv4 unicast autonomous-system 1
!
af-interface Ethernet0/2
summary-address 0.0.0.0 0.0.0.0
authentication mode md5
authentication key-chain myKey
exit-af-interface
!
network 192.168.24.0

Again nothing really new but note the name of the virtual router instance (weee/somethingelse) as no significance outside the local router and aren’t required to match.
I’ll go on to look at named config using VRFs in an upcoming post. Its worth noting you can also run “eigrp upgrade-cli” to get IOS to do all the work for you (if you have faith?) http://www.cisco.com/c/en/us/td/docs/ios-xml/ios/iproute_eigrp/configuration/xe-3s/ire-xe-3s-book/ire-classic-to-named.html

m00nie 🙂

Comments

Leave a Reply